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About Dragon View 
This section outlines the features and functionality of the Dragon View application which allows you to 
view XBRL Taxonomies and XBRL documents.  This section will include: 
 

• System Requirements 
• XBRL Taxonomy and XBRL document Overview 

 
Dragon View is an excellent review and comparison tool which can be used whether you tagged your 
documents using Rivet’s industry-leading Dragon Tag XBRL enabler markup solution, Rivet’s hosted 
CrossTag solution or another tagging product.   
Dragon View’s features allow you to: 
 

• Open any XBRL 2.1 compliant taxonomy (including company extension taxonomies) or documents  
• Filter documents according to View Types, Label Roles or Languages  
• Review taxonomy element information such as definitions, authoritative references and calculation 

hierarchies 
• Perform a basic search on both taxonomies and documents 
• Tailor a Markup Review Report which can be exported to Excel 
• Compare filings based upon elements used to a specific industry or all filers to the SEC 

 
System Requirements 
The following system capabilities are required to operate Dragon View: 
 

• Microsoft Windows XP Professional Edition, Windows VISTA 32-bit and 64-bit, Windows 
7 32-bit and 64-bit 

• Microsoft .NET Framework 2.0 
 
Note: It is necessary to have Microsoft Office Excel (2000, XP/2002, 2003 or 2007) installed on your computer in order to 
export to Excel to review data.. 
 
XBRL Taxonomy and XBRL Document Overview 
Dragon View allows you to open, review the details and export or print the data from any XBRL 
taxonomy or XBRL instance document.  When you first open Dragon View, you have the option from 
the File Menu to open an  
 

• XBRL Instance Document 
• US SEC Recent Filing 
• XBRL Taxonomy 
• US SEC Recent Taxonomy 
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XBRL Taxonomy:  An XBRL taxonomy is a collection of business reporting terms for a given 
reporting focus (i.e. financial reporting, earnings releases, tax reporting information, etc.) or industry (i.e. 
commercial and industrial, insurance, banking, etc.) that allows you to "mark up" or map your financial data to 
specific, agreed-upon reporting concepts. 
 
Two "types" of XBRL taxonomies are commonly referred to when working with XBRL taxonomies: "standard 
base" and "company extension" taxonomies.  From an XBRL 2.1 Specification standpoint, all XBRL 
taxonomies are created the same way. The use of the terms "standard base" and "company extension" when 
referring to XBRL taxonomies simply helps users better understand the difference between how these 
taxonomies are created and used by the market. 
 
Standard base taxonomies are typically provided by authoritative or regulatory bodies or the local jurisdiction 
of XBRL International. Examples of standard base taxonomies are US GAAP CI (Commercial and 
Industrial) and IFRS (International Financial Reporting Standards). Company extension taxonomies are 
created by companies or industry groups that "extend" a standard base taxonomy by adding additional 
information specific to a given company's or industry's type of reporting needs. Company extension 
taxonomy imports all of the information of a standard base taxonomy and allows additions or changes to the 
information contained in the standard base taxonomy without altering the integrity of the standard base 
taxonomy itself. 
 
Dragon View provides full support for both standard base and company extension taxonomies. 
Information contained within these taxonomies is presented by default based upon the presentation aspect 
of the given taxonomy (referred to as information contained in the presentation linkbase or presentation 
hierarchy) with additional options based upon the calculation (referred to as information contained in the 
calculation linkbase or calculation hierarchy) or element (flat alphabetic list) aspect also available. 
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XBRL Instance Document:  An XBRL instance document, on the other hand, is a collection of 
report data or "facts" created by a company that represents all or part of a business report. An XBRL instance 
document is, in its simplest form, the XBRL representation of existing business report information put in a 
globally- agreed upon technology easily understood by computers.  
 
The XBRL instance document contains information such as entity information (the company that the XBRL 
information came from), time periods, business segments, currency codes and amounts. It also contains 
the XBRL taxonomy elements (from standard base and/or extension taxonomies) that the company has 
identified as being specifically related to its financial information. The power of an XBRL document is that it 
communicates business report information in a common "language" while not forcing a company to 
change its reporting format or supply additional information (beyond what it already supplies today). 
 

 
 
The data elements contained in an XBRL instance document provide specific "pointers" back to specific 
taxonomies for information such as definitions, authoritative references and calculation methods. 
 
Although the XBRL instance document and XBRL taxonomy(s) are different physical files, Dragon View 
quickly and easily combines the content of the XBRL instance document with the related XBRL taxonomy to 
provide a single, report-like view of the information that is formatted like an accountant or financial 
professional would expect -like that of a structured financial statement/report. 
 
 
  

Instance document 
 

Extended taxonomy 
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US SEC Recent Filing:  Selecting this option to open, Dragon View will pull up the list of the 100 
most recent XBRL filings to the SEC as evidenced below.  You can browse using the scroll bar at the right 
hand side to see the companies or click on the columns to sort alphabetically or numerically to find a 
company you wish to view.  Then select, “Open Selected Filing” and Dragon View will populate with the all 
the data contained in that filing.   
 

 
 
US SEC Recent Taxonomy:  Selecting “Open Selected Taxonomy”, Dragon View will pull up 
the list of the 100 most recent XBRL filing extended taxonomies as illustrated below.  You can browse using 
the scroll bar at the right hand side to see the companies or click on the columns to sort alphabetically or 
numerically to find a company you wish to view.  Then select, “Open Selected Taxonomy” and Dragon View 
will populate with the extended taxonomy. 
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Using Dragon View 
Dragon View also allows you to open any Taxonomy or instance document such as one you may choose 
to file or one your competitors filed.  This section shows you how to begin using Dragon View, 
including any configuration or preparation.  
 
Getting Started 
When you launch Dragon View, you first see an opening Welcome Page from which you can access Dragon 
View's more common tasks such as opening taxonomy files, accessing instance documents, and viewing 
recently used files. You can also check for Dragon View updates, link to our support site or close the screen to 
continue entering Dragon View. 
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If you want to return to the welcome page, you can navigate to the “File” menu and select, “Return to 
Welcome Page” as illustrated below. 
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Opening Instance Documents 
Regardless of whether you open an SEC Filing or your own your instance document, when you open an 
instance document, you will see it show up with a tab with the name of the instance document and two 
tabs below, “Report Preview” and “Markup Review”.   
 

 
 
You can open multiple instance documents or taxonomies that will show up as separate tabs across the 
top, as illustrated below: 
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Report Preview:  This will show you exactly how your XBRL files will render or present.  For SEC 
Filers, this is an excellent tool to review exactly how your files will present given the formatting allowed with 
the SEC Interactive Viewer.  The formatting is shown to you in the Report Preview so you can review the 
following before it goes out the door: 

• Currency signs 
• Underlines 
• Headers 

 
 

 
 

 
Review headers 
 

Currency signs 
 
 
 
 
 
 
 
 
Underlines 
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In additional to reviewing the formatting of your instance document, you have the same functionality as on 
the SEC Interactive Viewer where you can review the elements within the instance document. 
 
 

 
 
Any other additional statements or disclosures contained within this filing can be reviewed individually by 
selecting the drop-down arrow and selecting the desired statement or disclosure.  Below you can see the 
Property, Plant & Equipment Note to review how it will render before you file. 
 

 
 
  

 
 
 
 
 
If you click on any line-item, 
such as inventory, a box will 
appear containing the definition 
and references, if applicable for 
that element. 
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Markup Review:  Selecting the Markup Review tab will generate the screen you see below.  The 
Markup Review allows you to review each individual element within your markup and the corresponding 
details.   
 
 

 
 
You have an option to add more detail by using the “Select / Deselect Columns” drop-down arrow.   
 
 

 
 
 
 
 
  

Your options include: 
• Extended (is the element extended or base) 
• Element Name (XML name) 
• Definition (of the element) 
• References (if applicable to the element) 
• Segments / Scenarios (that may be applied) 
• Balance Type (debit or credit) 
• Percentage of Total SEC Filers (see below) 
• Percentage of Total Filers for Selected SIC (see below) 
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Percentage of Total SEC Filers / Percentage of Total Filers for Selected 
SIC: 
Dragon View provides two columns comparing your elements selected to filers to the SEC to help 
provide a great comparison tool.  You can select the appropriate “SIC” code for comparison in the 
drop-down menu on the left.  The percentages will populate in the columns on the far right if selected. 
 

 
 
 
For example, the first element, “Cash and cash equivalents” is used by 96.77% of SEC Filers who have 
filed their XBRL data.  Within the SIC Code selected, 1040 – Gold and Silver Ores, 100% of filers in 
this SIC Code used this element as well.  This data provides a great tool to compare and review the 
elements you have selected with all filers to the SEC or your direct peers within your industry.  All 
percentages of 50% or greater will be highlighted in green, whereas all percentages less than 25% will be 
highlighted in pink. 
 
You also have the ability to sort within the Markup Review Tab.  Any of the columns have drop-down 
menus to help you sort depending on the data contained within.  In the example below, we can sort by 
extended elements or base elements by selecting, “yes” or “no” within the drop-down menu. 
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In addition to the drop-down menu of each column, you can double-click on a column to sort the data, such 
as “Percentage of All SEC Filers”.  In this example, sorted from highest to lowest percentage for elements we 
wish to review. 
 

 
 
Document Info: 
 

  The Information icon, , will bring up the box below, allowing you to open up detail on the 
filing including the taxonomy used and the instance document.  You can review the  

• Number of “Contexts” or calendar periods within the filing 
• Number of “Extended Elements” used in the filing 
• Number of elements used that fall below the 25% of SEC Filers or Filers within the SIC Code 
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Exporting Information:  Dragon View allows you to export an XBRL document or taxonomy into 
Microsoft Office Excel or to HTML depending on the version of Dragon View.  These are excellent features 
for review or analysis. Navigate to the “File” menu and select “Export to Excel” or “Export to HTML” 
 

 
 
 
Export to Excel:  Select the appropriate statements you wish to include in the export.   
Note: Whichever tab you are in is what will be exported.  If you are in the “Markup Review” tab, all the 
selected columns you see will export to Excel.  If you are in a taxonomy file, please select expand all before you 
export to excel. 
 

 
 

Column  Description  
Document Type  Displays the type of document to 

be exported to Excel  
Document Name  Displays the name of the document 

to be exported to Excel  
View Type  Displays the selected view of the 

taxonomy or instance document to 
be exported to Excel  

 

Export to Excel:  This feature is only available in the 
Presentation Edition of Dragon View.  Allows you to export 
the Markup Review to an excel spreadsheet.  When selected, a box 
will appear allowing you to filter what parts of the instance 
document (specific statements or disclosures or all) you wish to 
export to excel. 
 
Export to HTML:  This feature is only available in the 
Presentation Edition of Dragon View.  This will generate an 
HTML rendering of your files which can be used for others 
within the company or externally to review the presentation of the 
instance document including all the formatting of the files. 
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Export to HTML:  When you select, “Export to HTML” you will then be prompted to 
navigate to the folder where you want the HTML files saved.  Once the folder has been 
designated, Dragon View will save the files in the folder with each statement or disclosure having 
its own HTML document as illustrated below. 
 

 
 
You can double-click on the “index.hmtl” file it will bring up an internet window with a list of all 
the statements and disclosures contained in the filing on the left-hand side and a rendering of 
those statement or disclosure on the right-hand side..   
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Opening Taxonomies 
When you first open the taxonomy, you will see the taxonomy loaded as a tab within Dragon View and 
then you will have several options.   
 
To begin, you will want to go to the “View” menu and select, “Expand All”.  Now you will see the entire 
selected statement, such as the Balance Sheet, expanded as illustrated below.  You can use the “Search” 
box to look for an element or use the scroll bar.  You also have an option to change the “View Type” of 
the taxonomy as well. 
 
 

 
 
Options  Description  
View Type  Lets you select either the Presentation, Calculation, and 

Element view types.  
Label  Enables you to view one or more of the label roles 

contained within the taxonomy.  
Language  Enables you to view one or more of the languages in the 

taxonomy.  
Reports  Allows you to view the reports within the taxonomy.  
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General Options and Settings 
The View, Tools, Window and Help Menus within Dragon View provide the user with the capability to 
tailor their settings and options.   
 
Show Data Grid: 
Navigate to the “View” drop-down menu to select “Show Data Grid.”  
 

 
 

The data grid allows you to see additional detail that may not be available in the markup review. 
Note:  The “Show Data Grid” is not selected as the default setting. 
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Dragon View Options: 
From the “Tools” menu, select Options to display the Options dialog box: 
 

 
 
 

 
 
Item  Function  
Display prohibited items  Shows or hides prohibited items in the XBRL 

document or taxonomy.  
Display Missing Info Message when loading 
Instance documents  

Toggles on or off the ability to display the Missing Info  

Sort calendar periods in ascending order Arranges calendar periods by the most recent, down to 
the oldest 

Sort calendar periods in descending order Arranges calendar periods by the oldest to the most 
recent 

Recently used file list Controls the number of recently used files you want to 
display in the File Menu 

Definition/Authoritative References 
 

Definition: a dictionary-style definition of an 
element contained in the XBRL taxonomy. 
Authoritative References: specific references to 
authoritative literature that provides specific 
substantiation for an element. 
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Context / Element Detail 
 

Display element metadata 

Calculation Hierarchy 
 

The Calculation Hierarchy review pane displays the 
factors, if any used, in rolling up the total amount 
calculated for a data element 
 

 
Window Options:  This menu allows you to arrange your documents in a tiled format, tabbed or 
cascaded.  Navigate to the “Window” drop-down menu and choose from the following: 
 

 
 
Item  Functions  
Tabbed  Displays the open documents in a tabular format, similar to a 

row of file folders  
Cascaded  Displays the open documents in a cascaded list, which you can 

then sort through with your mouse  
Tiled - Horizontal  Arranges the open documents within the Dragon View 

workspace in a horizontal format  
Tiled - Vertical  Arranges the open documents within the Dragon View 

workspace in a vertical format  
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Dragon View Event Log:  Navigate to the “Help” menu and select, “View Event Log” to 
display the Event Log.  Use the scroll bar on the far right to see the different events and review 
the information about them in the viewing pane. 
 

 
 
 

 
 

Within the Help menu, you will also be able to: 
• Access the User’s Guide 
• Check Installation of Dragon View 
• Activate Product with your license key 
• Determine what version of Dragon View you have installed 

by selecting, “About Dragon View” 
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